Building Yasai

Yasai requires Qt 5.0.1 and lib7zip.

To build lib7zip, refer to the instructions here:
https://code.google.com/p/lib7zip/

Qt is available as pre-built binaries here:
https://qt-project.org/

On Windows
Yasai was built using MinGW (gcc 4.7.2, sjlj exception handing, and posix threading).
http://origin.releases.qt-project.org/prebuilt/mingw_32/

Known issues

  • Networked drives may not be traversable.
  • Images not in archives cannot be viewed side-by-side.
  • Fitting image to width or height fits the image to the width or height of the viewport without accounting for scrollbars.

Last edited Apr 8, 2013 at 8:34 AM by julianwong, version 7